Le 29 juin 2016 nous avons migré l’ensemble de nos services vers une nouvelle infrastructure d’hébergement.

Lors de cette migration, nous avons mis en place une logique de Virtual Hosting SSL permettant d’associer un certificat SSL à plusieurs adresses IP (correspondant à nos différents serveurs).

Pour cela nous avons utilisé l’extension SNI (Server Name Indication) du protocole TLS.

Cependant, cela nécessite que les applications clientes qui effectuent des requêtes sur nos serveurs supportent l’extension SNI.

Cela concerne :

  • Les navigateurs obsolètes souhaitant se rendre sur Sellsy
  • Les applications clientes utilisant notre API

Cas n°1 : Il suffit en général de mettre à jour le navigateur. Cas spécial, IE sous Windows XP qui ne peut le supporter. Il faut donc mettre à jour votre navigateur ou votre système d’exploitation.

Cas n°2 : il faut mettre à jour l’applicatif serveur, en installant une version supportant SNI.

Nous vous conseillons de lire cet article vous présentant le fonctionnement de SNI et les supports pour lequel il est compatible.